从5.x版本更新

在大多数情况下,NexT V5 版本仍然能够正常运行,但是如果你想获得更多的功能和帮助,还是建议您升级到 NexT V6+ 版本,并移步 Theme-Next 仓库。

在 5.1.x 版本和新版本之间没有很大的革命性改进。主版本号变更至 6 主要是因为:

  1. 主仓库已从 iissnan 名下 迁移至 theme-next 组织。
  2. next/source/lib 目录下的绝大多数库被移出到了 NexT 组织的外部仓库中。
  3. 第三方插件 hexo-wordcounthexo-symbols-count-time 所取代,因为 hexo-symbols-count-time 没有任何外部 nodejs 依赖、也没有会导致生成站点时的性能问题 language filter

推荐通过如下步骤从 v5 升级到 v6:

  1. 并不修改原有的 next 目录,而只是复制部分 NexT 文件:

    1. _config.ymlnext.yml(如果你使用了数据文件)。
    2. 自定义的 CSS 配置,它们应在 next/source/css/_custom/*next/source/css/_variables/* 中。
    3. 自定义的排布配置,它们应在 next/layout/_custom/* 中。
    4. 任何其它可能的附加自定义内容;为了定位它们,你可以通过某些工具在仓库间比较。
  2. 克隆新的仓库到任一异于 next 的目录(如 next-reloaded):

    1
    $ git clone https://github.com/theme-next/hexo-theme-next themes/next-reloaded

    如此,你可以在不修改原有的 NexT v5.1.x 目录的同时使用 next-reloaded 目录中的新版本主题。

  3. 在 Hexo 的主配置文件中设置主题:

    1
    2
    3
    ...
    theme: next-reloaded
    ...

    如此,你的 next-reloaded 主题将在生成站点时被加载。如果你遇到了任何错误、或只是不喜欢这一新版本,你可以随时切换回旧的 v5.1.x 版本。

  4. 更新语言配置

    从 v6.0.3 版本起,zh-Hans 改名为 zh-CNhttps://github.com/theme-next/hexo-theme-next/releases/tag/v6.0.3

    升级到 v6.0.3 及以后版本的用户,需要显式修改 Hexo 主配置文件 _config.yml 里的 language 配置,否则语言显示不正确。

关于第三方库的启用,参见这里